summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/slixmpp/slixmpp-9999.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 2a4e8a61ee40..5aa7dcaa46e9 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -3,18 +3,22 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Python 3 library for XMPP"
-HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+HOMEPAGE="
+ https://codeberg.org/poezio/slixmpp/
+ https://pypi.org/project/slixmpp/
+"
LICENSE="MIT"
SLOT="0"
if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git https://github.com/poezio/slixmpp.git"
+ EGIT_REPO_URI="https://codeberg.org/poezio/slixmpp.git"
inherit git-r3
else
inherit pypi