summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sortedcollections/sortedcollections-0.5.3.ebuild')
-rw-r--r--dev-python/sortedcollections/sortedcollections-0.5.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
new file mode 100644
index 000000000000..31c883ffaa6f
--- /dev/null
+++ b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/$(echo ${PN} | cut -c 1)/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}