summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-bootstrap-theme')
-rw-r--r--dev-python/sphinx-bootstrap-theme/Manifest2
-rw-r--r--dev-python/sphinx-bootstrap-theme/metadata.xml2
-rw-r--r--dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.0.ebuild19
-rw-r--r--dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild38
4 files changed, 40 insertions, 21 deletions
diff --git a/dev-python/sphinx-bootstrap-theme/Manifest b/dev-python/sphinx-bootstrap-theme/Manifest
index be4a81864289..f7e79f174b57 100644
--- a/dev-python/sphinx-bootstrap-theme/Manifest
+++ b/dev-python/sphinx-bootstrap-theme/Manifest
@@ -1 +1 @@
-DIST sphinx-bootstrap-theme-0.8.0.tar.gz 1225612 BLAKE2B db5e65db732163048909903c7af0eb301a81b12fbf9ce299070d55ea8f949e2094f3c5624182fd8ac625d553f982cba6ef1bc0c2680de55993d57e82a779956a SHA512 25a2d05c424c52d4571e9a50a55be0c7f3a32aa855c3fe6fb642b1afcebcabb0fa715aac48da280a556b6c8d206b7018b45d8f9bd092123a9c03940290bbfc63
+DIST sphinx-bootstrap-theme-0.8.1.gh.tar.gz 1228936 BLAKE2B 1f7d83052cd8f7b5cc8ec89279e591eab46ea3db11562dac8d92f9050b47fe5ab28939a17e4e48178096cd161275af7fb3047c91a4a5c405b9a8f848625893dc SHA512 de56b56bbb729c9d4f98697a1d312555ddb22c05588fb00e0417075f8b500a6cb09c8918276f4a59900ceec1374f1355cd4919b012505a37481de970f0172399
diff --git a/dev-python/sphinx-bootstrap-theme/metadata.xml b/dev-python/sphinx-bootstrap-theme/metadata.xml
index 71c8f4a9f9c8..01307197b7ef 100644
--- a/dev-python/sphinx-bootstrap-theme/metadata.xml
+++ b/dev-python/sphinx-bootstrap-theme/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
diff --git a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.0.ebuild b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.0.ebuild
deleted file mode 100644
index b67727c008a9..000000000000
--- a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx theme integrates the Bootstrap CSS / JavaScript framework"
-HOMEPAGE="https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html"
-# Latest version isn't on PyPI
-# https://github.com/ryan-roemer/sphinx-bootstrap-theme/issues/210
-SRC_URI="https://github.com/ryan-roemer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
diff --git a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
new file mode 100644
index 000000000000..137ceb158040
--- /dev/null
+++ b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx theme integrates the Bootstrap CSS / JavaScript framework"
+HOMEPAGE="
+ https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/
+ https://pypi.org/project/sphinx-bootstrap-theme/
+"
+SRC_URI="
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd demo || die
+ "${EPYTHON}" -m sphinx -d "${BUILD_DIR}"/doctrees \
+ -b html source "${BUILD_DIR}"/html || die
+}