summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-jinja/sphinx-jinja-0.2.1.ebuild')
-rw-r--r--dev-python/sphinx-jinja/sphinx-jinja-0.2.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/sphinx-jinja/sphinx-jinja-0.2.1.ebuild b/dev-python/sphinx-jinja/sphinx-jinja-0.2.1.ebuild
deleted file mode 100644
index c5132f939caf..000000000000
--- a/dev-python/sphinx-jinja/sphinx-jinja-0.2.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A sphinx extension to include jinja based templates into a sphinx doc"
-HOMEPAGE="https://github.com/tardyp/sphinx-jinja https://pypi.org/project/sphinx-jinja/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/sphinx-testing[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- if python_is_python3; then
- sed -i -e "s/import urllib/import urllib.request as urllib/" sphinxcontrib/jinja.py || die
- fi
-}
-
-python_test() {
- nosetests || die
-}