summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-terminal/spyder-terminal-0.5.0.ebuild')
-rw-r--r--dev-python/spyder-terminal/spyder-terminal-0.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/spyder-terminal/spyder-terminal-0.5.0.ebuild b/dev-python/spyder-terminal/spyder-terminal-0.5.0.ebuild
new file mode 100644
index 000000000000..2769afc44379
--- /dev/null
+++ b/dev-python/spyder-terminal/spyder-terminal-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Run system terminals inside Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-terminal"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.9.1[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"