summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild')
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
deleted file mode 100644
index 43ce967da1ec..000000000000
--- a/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 virtualx
-
-COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
-
-DESCRIPTION="Plugin for Spyder to run tests and view the results"
-HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-# AttributeError: 'NoneType' object has no attribute 'split'
-RESTRICT="test"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/spyder-5.3.1[${PYTHON_USEDEP}]
- <dev-python/spyder-6[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-
-python_test() {
- virtx epytest
-}