summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-vim')
-rw-r--r--dev-python/spyder-vim/Manifest1
-rw-r--r--dev-python/spyder-vim/spyder-vim-0.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/spyder-vim/Manifest b/dev-python/spyder-vim/Manifest
index 483db2d30035..1db674fa7b7d 100644
--- a/dev-python/spyder-vim/Manifest
+++ b/dev-python/spyder-vim/Manifest
@@ -1 +1,2 @@
+DIST spyder-vim-0.1.0.gh.tar.gz 867270 BLAKE2B 23f8d880bfbb168f4c6260cd19ac90aeef7413a825e4023d3e2f9fd6296f96f36792f553a98f458cb452d7f6a80f0b1bb7a31a4e4aa25bf3127cf3dafb600a85 SHA512 4671850782113e5c801ccb058bed036fb0675d817714929bcdf247f9819a25378925d20d4216cd9d6eba621be1c56b45631a9796c2b80f0a0b24cdc79c20d715
DIST spyder-vim-0_pre20220831.gh.tar.gz 293646 BLAKE2B 19c7ed461f924c441da3454d510e5782b66139de41febd2cbb5968a0f00a63a0751e7206328d73287dc9c64cdc22d9e4a5936a312b7775d55e95b68c26d270d8 SHA512 a55f41dca60c6ab6046d13d8a1baa8b8f565542c4d02bfdd931ad1daaaedae372853baa65374f553a6e73d22c234e753375936cf4be18dc4f0d342507e479031
diff --git a/dev-python/spyder-vim/spyder-vim-0.1.0.ebuild b/dev-python/spyder-vim/spyder-vim-0.1.0.ebuild
new file mode 100644
index 000000000000..5f987fdd7126
--- /dev/null
+++ b/dev-python/spyder-vim/spyder-vim-0.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin for Spyder to enable Vim keybindings"
+HOMEPAGE="https://github.com/spyder-ide/spyder-vim"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/spyder-5.3.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ "
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "doc/example.gif" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}