summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlparse/sqlparse-0.3.0.ebuild')
-rw-r--r--dev-python/sqlparse/sqlparse-0.3.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/sqlparse/sqlparse-0.3.0.ebuild b/dev-python/sqlparse/sqlparse-0.3.0.ebuild
deleted file mode 100644
index b009b59c5486..000000000000
--- a/dev-python/sqlparse/sqlparse-0.3.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-MY_PN="${PN##python-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A non-validating SQL parser module for Python"
-HOMEPAGE="https://github.com/andialbrecht/sqlparse"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD-2"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${P#python-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- pytest tests || die "testsuite failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}