summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.1.4.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild
new file mode 100644
index 000000000000..4aeb081ac92f
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~arm"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/tox[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}