summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/svgwrite/svgwrite-1.2.1.ebuild')
-rw-r--r--dev-python/svgwrite/svgwrite-1.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.2.1.ebuild b/dev-python/svgwrite/svgwrite-1.2.1.ebuild
new file mode 100644
index 000000000000..aa6acd5719f2
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}