summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sympy/sympy-1.12.ebuild')
-rw-r--r--dev-python/sympy/sympy-1.12.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/sympy/sympy-1.12.ebuild b/dev-python/sympy/sympy-1.12.ebuild
index 588e766d8a3a..83dca584780b 100644
--- a/dev-python/sympy/sympy-1.12.ebuild
+++ b/dev-python/sympy/sympy-1.12.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 virtualx
@@ -78,6 +78,15 @@ python_test() {
sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
)
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://foss.heptapod.net/pypy/pypy/-/issues/4032
+ sympy/tensor/array/tests/test_array_comprehension.py::test_arraycomprehensionmap
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
nonfatal epytest --veryquickcheck ||
die -n "Tests failed with ${EPYTHON}"