summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/Manifest2
-rw-r--r--dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch29
-rw-r--r--dev-python/tagpy/metadata.xml11
-rw-r--r--dev-python/tagpy/tagpy-0.94.8-r1.ebuild54
-rw-r--r--dev-python/tagpy/tagpy-2013.1.ebuild37
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-python/tagpy/Manifest b/dev-python/tagpy/Manifest
new file mode 100644
index 000000000000..4eab93223abb
--- /dev/null
+++ b/dev-python/tagpy/Manifest
@@ -0,0 +1,2 @@
+DIST tagpy-0.94.8.tar.gz 151986 SHA256 56eab8dd81510f8af18e19375a0ffd5cd25c8e555104be46a92c3dc08634a0dc SHA512 430ae545065e5358dab6021a47b3b176934bc0901058daace35f98b645f7b087859930566d951c30e0e03d91ad46771a5bddc2a6f48a7196cf66b994699b39f1 WHIRLPOOL 164a2c56f86c7174976c9c5d55cf4097a0b992809812524a63a6c2bf4476d189fdb8dad01431ce2b62337a57d25efea90081a2291bb396345dac15f79a3d3056
+DIST tagpy-2013.1.tar.gz 151463 SHA256 80481c78ce34878e7a1f3231acd781a3bf1b0b569c70ce0e8d63af58061152f4 SHA512 4068b33fcbee2d5037149fda3ad0b256a31187ee35146392d0e187acb1d8e57c249da5356cb396cb9f027ed47ff44016466a1faaea0912494535c631f8271d58 WHIRLPOOL b47f349bc7f328ee4c18856e7f817f35868529afa0b7a820ec614cb003b3f4c4c84fabc4bd6c5a93ce12d0721e9127cf0dc806df4977fbb505934b9ba5233c20
diff --git a/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch b/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch
new file mode 100644
index 000000000000..084ea983a6d7
--- /dev/null
+++ b/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch
@@ -0,0 +1,29 @@
+https://github.com/inducer/tagpy/commit/d0759c0ec7d24ae8d1af395a1032521eb00b4d1f
+https://github.com/inducer/tagpy/commit/813ec4f03bb4411c7ffd15dcb3974da04a3f109c
+
+--- tagpy-0.94.8/src/wrapper/id3.cpp
++++ tagpy-0.94.8/src/wrapper/id3.cpp
+@@ -79,6 +79,10 @@
+ MF_OL(setVolumeAdjustment, 1, 2);
+ MF_OL(setPeakVolume, 1, 2);
+
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ MF_OL(render, 0, 1)
++ #endif
++
+ // -------------------------------------------------------------
+ // MPEG
+ // -------------------------------------------------------------
+@@ -212,7 +216,11 @@
+ .DEF_SIMPLE_METHOD(removeFrame)
+ .DEF_SIMPLE_METHOD(removeFrames)
+
+- .DEF_SIMPLE_METHOD(render)
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)(int) const)
++ #else
++ .DEF_SIMPLE_METHOD(render)
++ #endif
+ ;
+ }
+
diff --git a/dev-python/tagpy/metadata.xml b/dev-python/tagpy/metadata.xml
new file mode 100644
index 000000000000..92c517ef03a8
--- /dev/null
+++ b/dev-python/tagpy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">TagPy is a Python crust (or a set of Python bindings) for Scott
+ Wheeler's TagLib. It builds upon Boost.Python, a wrapper generation
+ library which is part of the Boost set of C++ libraries.</longdescription>
+ <upstream>
+ <remote-id type="pypi">tagpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tagpy/tagpy-0.94.8-r1.ebuild b/dev-python/tagpy/tagpy-0.94.8-r1.ebuild
new file mode 100644
index 000000000000..bf0810f2c3a0
--- /dev/null
+++ b/dev-python/tagpy/tagpy-0.94.8-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/boost-1.48[python]
+ >=media-libs/taglib-1.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_prepare() {
+ # bug #440740
+ epatch "${FILESDIR}"/${P}-taglib-1.8_compat.patch
+
+ # Disable broken check for Distribute.
+ sed -e "s/if 'distribute' not in setuptools.__file__:/if False:/" -i aksetup_helper.py
+
+ distutils_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ "$(PYTHON)" configure.py \
+ --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ --boost-python-libname="boost_python-${PYTHON_ABI}-mt"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+ fi
+}
diff --git a/dev-python/tagpy/tagpy-2013.1.ebuild b/dev-python/tagpy/tagpy-2013.1.ebuild
new file mode 100644
index 000000000000..ccea56b1bfd9
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2013.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/boost-1.49.0[python]
+ >=media-libs/taglib-1.7.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_configure() {
+ "${PYTHON}" configure.py \
+ --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ --boost-python-libname="boost_python-${EPYTHON#python}"
+ distutils-r1_python_configure
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( test/* )
+
+ distutils-r1_python_install_all
+}