summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tavalidate/tavalidate-0.0.6-r1.ebuild')
-rw-r--r--dev-python/tavalidate/tavalidate-0.0.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tavalidate/tavalidate-0.0.6-r1.ebuild b/dev-python/tavalidate/tavalidate-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..c8fb584de742
--- /dev/null
+++ b/dev-python/tavalidate/tavalidate-0.0.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utities to validate Tavern responses"
+HOMEPAGE="
+ https://github.com/sohoffice/tavalidate/
+ https://pypi.org/project/tavalidate/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ >=dev-python/lxml-4.0.0[${PYTHON_USEDEP}]
+ dev-python/python-box[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest