summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempora/tempora-1.9.ebuild')
-rw-r--r--dev-python/tempora/tempora-1.9.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/tempora/tempora-1.9.ebuild b/dev-python/tempora/tempora-1.9.ebuild
deleted file mode 100644
index 1ec62eceaa99..000000000000
--- a/dev-python/tempora/tempora-1.9.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-# The calc-prorate binary used to be part of jaraco.utils
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- !<=dev-python/jaraco-utils-10.0.2
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}