summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tempora/tempora-5.5.1.ebuild')
-rw-r--r--dev-python/tempora/tempora-5.5.1.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/dev-python/tempora/tempora-5.5.1.ebuild b/dev-python/tempora/tempora-5.5.1.ebuild
index 736a04fbab4f..0a0302c6d6d0 100644
--- a/dev-python/tempora/tempora-5.5.1.ebuild
+++ b/dev-python/tempora/tempora-5.5.1.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_TESTED=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
inherit distutils-r1 pypi
@@ -25,9 +26,21 @@ RDEPEND="
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
)
"
distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p freezegun
+}