summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/terminaltables')
-rw-r--r--dev-python/terminaltables/Manifest1
-rw-r--r--dev-python/terminaltables/metadata.xml2
-rw-r--r--dev-python/terminaltables/terminaltables-3.1.10.ebuild39
-rw-r--r--dev-python/terminaltables/terminaltables-9999.ebuild9
4 files changed, 46 insertions, 5 deletions
diff --git a/dev-python/terminaltables/Manifest b/dev-python/terminaltables/Manifest
index 6ce24a37c03c..9b87fce62975 100644
--- a/dev-python/terminaltables/Manifest
+++ b/dev-python/terminaltables/Manifest
@@ -1 +1,2 @@
DIST terminaltables-3.1.0.tar.gz 278484 BLAKE2B 733bcfcdc51c5e78e85e8f7fc9db00fa96c1ad48f76a9ec48ed546dc0acd62af90f437de346fe05d4cb09151b33ddea2f62beb21b418d7f76d8a719423a5f694 SHA512 dc49458652fff8bc6094d316d84c9b8e9fca1a26e3230c0b668bc03ec8528793f4ef024e8032d4a56fbfabfdfd4a1142870f550f0b373ba6a42dd2e3ead3f501
+DIST terminaltables-3.1.10.tar.gz 282122 BLAKE2B 53d5ecde38370f5b05d3eaae4b618ada6991214feadc7e826467dafede5baaf8292e47e6b2be903eb8ae6d46e3066314fe7950d7330056cd3053e0d643ad1a9e SHA512 84fa403cee4206b6b19de0206d89535bd2965a0796e1890dd9b0a9c6593c5f41d0d24b88ee9db426067c777712a4e810d67d4d0246496239a7a96b53a24e8174
diff --git a/dev-python/terminaltables/metadata.xml b/dev-python/terminaltables/metadata.xml
index f8a843fcbfdf..38af7ae0ae2b 100644
--- a/dev-python/terminaltables/metadata.xml
+++ b/dev-python/terminaltables/metadata.xml
@@ -10,7 +10,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">Robpol86/terminaltables</remote-id>
+ <remote-id type="github">matthewdeanmartin/terminaltables</remote-id>
<remote-id type="pypi">terminaltables</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/terminaltables/terminaltables-3.1.10.ebuild b/dev-python/terminaltables/terminaltables-3.1.10.ebuild
new file mode 100644
index 000000000000..a1a015395675
--- /dev/null
+++ b/dev-python/terminaltables/terminaltables-3.1.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
+HOMEPAGE="https://robpol86.github.io/terminaltables/"
+SRC_URI="
+ https://github.com/matthewdeanmartin/terminaltables/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/terminaltables-3.1.0-stdout.patch
+)
+
+src_prepare() {
+ # workaround pp2sp complaining about unsupported exclude,
+ # even though it's empty (fix will be included in pp2sp-22)
+ sed -i -e 's:^exclude:empty-&:' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/terminaltables/terminaltables-9999.ebuild b/dev-python/terminaltables/terminaltables-9999.ebuild
index f20c73f288fc..ed12c5a82704 100644
--- a/dev-python/terminaltables/terminaltables-9999.ebuild
+++ b/dev-python/terminaltables/terminaltables-9999.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( python3_{7..10} )
-EGIT_REPO_URI="https://github.com/Robpol86/${PN}.git"
inherit distutils-r1 git-r3
DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
HOMEPAGE="https://robpol86.github.io/terminaltables/"
-SRC_URI=""
+EGIT_REPO_URI="https://github.com/matthewdeanmartin/${PN}.git"
LICENSE="MIT"
SLOT="0"