summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/textile')
-rw-r--r--dev-python/textile/Manifest1
-rw-r--r--dev-python/textile/metadata.xml15
-rw-r--r--dev-python/textile/textile-4.0.2.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/textile/Manifest b/dev-python/textile/Manifest
new file mode 100644
index 000000000000..7f0d8ee5ac4d
--- /dev/null
+++ b/dev-python/textile/Manifest
@@ -0,0 +1 @@
+DIST python-textile-4.0.2.gh.tar.gz 49296 BLAKE2B e9ac36b0ecf401a07aea1037c1f4390e440123d7e16f8fef64c257d27f6ef9c6918018ff34e9f8ad367767f3ebc5ce7957be424b2e6dac62fe8a1f7736b8eff7 SHA512 eb59e44b9a8521bcfa98f476e23efd727ffd867277d24f102bbb9511a99a0d636c324e22f8562382074007f304490c4ec6a5fde529f41b15f055a9cf16d49b8e
diff --git a/dev-python/textile/metadata.xml b/dev-python/textile/metadata.xml
new file mode 100644
index 000000000000..9fcb3d2c7ea1
--- /dev/null
+++ b/dev-python/textile/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">A Python implementation of Textile, Dean Allen's Human Text Generator.
+ Textile simplifies the work of creating (X)HTML.</longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">textile</remote-id>
+ <remote-id type="github">textile/python-textile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/textile/textile-4.0.2.ebuild b/dev-python/textile/textile-4.0.2.ebuild
new file mode 100644
index 000000000000..c946d2963386
--- /dev/null
+++ b/dev-python/textile/textile-4.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="python-textile-${PV}"
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="
+ https://github.com/textile/python-textile/
+ https://pypi.org/project/textile/
+"
+SRC_URI="
+ https://github.com/textile/python-textile/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # tests that need network access
+ tests/test_getimagesize.py
+ tests/test_imagesize.py
+ tests/test_textile.py
+ )
+ epytest -o addopts=
+}