summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tracing/tracing-0.10.ebuild')
-rw-r--r--dev-python/tracing/tracing-0.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tracing/tracing-0.10.ebuild b/dev-python/tracing/tracing-0.10.ebuild
new file mode 100644
index 000000000000..703528ecfa0a
--- /dev/null
+++ b/dev-python/tracing/tracing-0.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Debug log/trace messages"
+HOMEPAGE="http://liw.fi/tracing/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/python-tracing/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r doc/_build/html/
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto usr/share/doc/${PF}/examples/
+ doins example.py
+ fi
+}