summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/transitions/transitions-0.9.1.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.9.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.9.1.ebuild b/dev-python/transitions/transitions-0.9.1.ebuild
new file mode 100644
index 000000000000..3951e621e04c
--- /dev/null
+++ b/dev-python/transitions/transitions-0.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="
+ https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # magic to ignore async tests sometimes, breaks EPYTEST_IGNORE
+ [[ ${PV} != 0.9.1 ]] && die "Remove this hack"
+ rm conftest.py || die
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # pycodestyle, mypy, etc.
+ tests/test_codestyle.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc examples/*.ipynb
+}