summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.2.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 50024f5abdcc..eca32fbc413e 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,4 @@
DIST trimesh-4.1.8.gh.tar.gz 13440336 BLAKE2B aa4bddc3d613144a0e304ec320a2b38df213846260e2525dae0f0f35a4146561e7b81dc88e197a5b0f0a76ff4b757c30df2a68fe0db0d4a37cdc8a91aedc41ba SHA512 e20ca45f08a4d65c44c214b104af7c6d9d27121716ed7efd53a521c5b896ce788dba91b7794db518f26bb2ae86a1b8269af94f9b9381f8fdd342372b4ba86ce4
DIST trimesh-4.2.0.gh.tar.gz 13553809 BLAKE2B 141aec46cb8bf2342251a72e5e4c1fbee1e33e4ff63d420cfa4db1758fc324d572d54932ce1526ba2df75d9770f001d9dbe41a79835837931c4c46221fbb6871 SHA512 75efd00ef5ff8f9c25bdfb06ab92fa09db154771356b18ebcf457cba4c2f366645084eb078e5e324cfb41fe101797694aa6b00005f7ccd1290ba4d2d6c088ebd
DIST trimesh-4.2.1.gh.tar.gz 13554447 BLAKE2B 02b75d8768963c250bbc1ebb75815567736a74b288da2a781b83fc3d31934059ebb85115c2e556a29da6c0e3034714226addba062d776acca4953414d1ed3492 SHA512 bdcd8436869849e8e8897732e0b9f8390d0771ea8dcadabb108ee8245d75c4d0ac915456473b6b0ed4f2f27fad48e123511e0bcfc79d485119376290c6f6d311
+DIST trimesh-4.2.3.gh.tar.gz 13554586 BLAKE2B 2c82690a17d8c62c80c99e87d9347ab85c14b2170fbdccc7967f893f6d83bed9aa2e38ef3f024567893d926511b34b20109bb94c8e976ced9d7a77190a653f14 SHA512 541438e5f5bd577af693bb238b308c7094b334530d7a962881e05db81331e1c896c82f76b0dcd4bfa17abcfec9eadf869bb0cad01e1402e99852c3ff2d184e5f
diff --git a/dev-python/trimesh/trimesh-4.2.3.ebuild b/dev-python/trimesh/trimesh-4.2.3.ebuild
new file mode 100644
index 000000000000..1efbb5f219c0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.2.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}