summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tubes/tubes-0.2.0-r1.ebuild')
-rw-r--r--dev-python/tubes/tubes-0.2.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tubes/tubes-0.2.0-r1.ebuild b/dev-python/tubes/tubes-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..e9e16492a5cb
--- /dev/null
+++ b/dev-python/tubes/tubes-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit distutils-r1
+
+DESCRIPTION="Flow control and backpressure for event-driven applications"
+HOMEPAGE="https://github.com/twisted/tubes https://pypi.org/project/Tubes/"
+SRC_URI="https://github.com/twisted/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 "
+
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "$FILESDIR/remove-unnecessary-dep.patch")
+
+distutils_enable_tests pytest