summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/Manifest2
-rw-r--r--dev-python/txaio/metadata.xml4
-rw-r--r--dev-python/txaio/txaio-22.2.1.ebuild44
-rw-r--r--dev-python/txaio/txaio-23.1.1.ebuild33
4 files changed, 34 insertions, 49 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index 1b6fde8f7c16..459f42edc441 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1 +1 @@
-DIST txaio-22.2.1.tar.gz 53645 BLAKE2B 375203ddbe65d293ba0bf85e316880d552f47cbc9008bd41e50976ee097940c626ec66ad25e0b5322493f71f77141d03f543ce9c9d83268a1a896b16f434ccaa SHA512 b5e33ba671ab215dadf4c348b01e9d5057d080c21707d31e38912fe596aabd7b388e8c5e0f2dd2b7d0d09fe0a175a0906e2a2ee428c1a943e786afa79182631e
+DIST txaio-23.1.1.tar.gz 53704 BLAKE2B 1c12892c34cc848732d718a715e83059a6be0973cbabe619639c67d230b0d4e55b4e6d1b13baa05b13fe9faa266dadb6f2913bc01491af381fde5ca78ce6941e SHA512 41320501ec3e2555edc63326f2c5ee9bbc2fd103198a515b6dc4c44603a41d633c99a8f12c92ffc85f43546f0382d40f0c9748b13f7a7e70d98c5c4a2de85e2e
diff --git a/dev-python/txaio/metadata.xml b/dev-python/txaio/metadata.xml
index 26a77153d753..6026f75d328a 100644
--- a/dev-python/txaio/metadata.xml
+++ b/dev-python/txaio/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>dolsen@gentoo.org</email>
- <name>Brian Dolbec</name>
- </maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>
diff --git a/dev-python/txaio/txaio-22.2.1.ebuild b/dev-python/txaio/txaio-22.2.1.ebuild
deleted file mode 100644
index 9b967afe9b6f..000000000000
--- a/dev-python/txaio/txaio-22.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
-HOMEPAGE="
- https://github.com/crossbario/txaio/
- https://pypi.org/project/txaio/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-distutils_enable_sphinx docs \
- '>=dev-python/sphinxcontrib-spelling-2.1.2' \
- '>=dev-python/sphinx_rtd_theme-0.1.9'
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # we certainly don't need to test "python setup.py sdist" here
- test/test_packaging.py
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # tests for removed asyncio.coroutine
- test/test_as_future.py::test_as_future_coroutine
- test/test_call_later.py::test_explicit_reactor_coroutine
- test/test_is_future.py::test_is_future_coroutine
- )
-
- epytest
-}
-
-pkg_postinst() {
- optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
-}
diff --git a/dev-python/txaio/txaio-23.1.1.ebuild b/dev-python/txaio/txaio-23.1.1.ebuild
new file mode 100644
index 000000000000..babec5abf80d
--- /dev/null
+++ b/dev-python/txaio/txaio-23.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="
+ https://github.com/crossbario/txaio/
+ https://pypi.org/project/txaio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinxcontrib-spelling-2.1.2' \
+ '>=dev-python/sphinx-rtd-theme-0.1.9'
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # we certainly don't need to test "python setup.py sdist" here
+ test/test_packaging.py
+)
+
+pkg_postinst() {
+ optfeature "Twisted support" "dev-python/twisted dev-python/zope-interface"
+}