summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/typed-ast/typed-ast-1.4.3.ebuild')
-rw-r--r--dev-python/typed-ast/typed-ast-1.4.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/typed-ast/typed-ast-1.4.3.ebuild b/dev-python/typed-ast/typed-ast-1.4.3.ebuild
new file mode 100644
index 000000000000..a4e8f2034015
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.4.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}