summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ubelt/ubelt-0.11.1.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.11.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-0.11.1.ebuild b/dev-python/ubelt/ubelt-0.11.1.ebuild
new file mode 100644
index 000000000000..05531fa0f9eb
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.11.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)