summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ubelt/ubelt-0.9.5.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.9.5.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/ubelt/ubelt-0.9.5.ebuild b/dev-python/ubelt/ubelt-0.9.5.ebuild
deleted file mode 100644
index e906563da37c..000000000000
--- a/dev-python/ubelt/ubelt-0.9.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
-HOMEPAGE="https://github.com/Erotemic/ubelt"
-SRC_URI="https://github.com/Erotemic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-python/ordered-set[${PYTHON_USEDEP}]"
-
-DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # relies on passwd being equal to ${HOME}
- ubelt/util_path.py::userhome:0
- )
-
- epytest ${deselect[@]/#/--deselect } tests
-}