summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ubelt')
-rw-r--r--dev-python/ubelt/Manifest1
-rw-r--r--dev-python/ubelt/ubelt-1.3.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ubelt/Manifest b/dev-python/ubelt/Manifest
index 619251565c37..20873e088ae6 100644
--- a/dev-python/ubelt/Manifest
+++ b/dev-python/ubelt/Manifest
@@ -1 +1,2 @@
DIST ubelt-1.3.3.gh.tar.gz 348746 BLAKE2B e537b699a2f04efea9c2477437b7100bf9b736cb69c73ebc06bc639c8d9794c513447552e8c34430fce92b5c757369b447422ee9841ac1c6d2f47e292282d816 SHA512 77e03e06c03b6d8c8004b06f5bc843cbb4b1ad21c8c35d4801d5695c2556c707572a5f188a5774013c5ee0eda4005b593cc8548a3c025d460a21fbd996e41abb
+DIST ubelt-1.3.4.gh.tar.gz 353041 BLAKE2B 1de8ad1fc69554570f62c17fa537918b93d913e09db1d7c9b94ac9fa5f7b60a4a408f4c562718b9bbcf13e4307c091cf4ac24caa952233974d37cc6651e4786e SHA512 b3afc832832b28e7ca884c68188d34da9a1c3d5e38b5431cc40d8215fd43875f02cf71068e8b242feca0891f9421d3fba745d4236865beb5cb4f40482a777e13
diff --git a/dev-python/ubelt/ubelt-1.3.4.ebuild b/dev-python/ubelt/ubelt-1.3.4.ebuild
new file mode 100644
index 000000000000..fd7ff25c1032
--- /dev/null
+++ b/dev-python/ubelt/ubelt-1.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="
+ https://github.com/Erotemic/ubelt/
+ https://pypi.org/project/ubelt/
+"
+SRC_URI="
+ https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ dev-python/xdoctest[${PYTHON_USEDEP}]
+ >=dev-python/xxhash-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_editable_modules.py::test_import_of_editable_install
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)