summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uncompyle6/uncompyle6-2.8.3.ebuild')
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.8.3.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild b/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
index 1fdfe44f5ee9..3007cb166c0a 100644
--- a/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
+++ b/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
@@ -20,12 +20,21 @@ RDEPEND=">=dev-python/xdis-2.3.0
>=dev-python/spark-parser-1.4.0"
DEPEND="${RDEPEND}
test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
)
"
+python_prepare_all() {
+ # Fix an unconditional test only dep
+ sed \
+ -e "s/setup_requires/tests_require/" \
+ -i setup.py
+ distutils-r1_python_prepare_all
+}
+
# Tests are somewhat sketchy...
# the main repo has makefiles and commands that don't reflect the actual
# available options for the commands they are giving.