summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild')
-rw-r--r--dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
index d2096e37231e..e054fcb068e8 100644
--- a/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
+++ b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
@@ -1,25 +1,30 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
inherit distutils-r1
DESCRIPTION="URL normalization for Python"
HOMEPAGE="
https://github.com/niksite/url-normalize/
- https://pypi.org/project/url-normalize/"
+ https://pypi.org/project/url-normalize/
+"
SRC_URI="
https://github.com/niksite/url-normalize/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest