summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/utidylib/utidylib-0.6.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/utidylib/utidylib-0.6.ebuild b/dev-python/utidylib/utidylib-0.6.ebuild
new file mode 100644
index 000000000000..b37e9e1ddd2f
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ doc? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+ test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7) )
+ test? (
+ $(python_gen_cond_dep 'dev-python/flake8[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+ $(python_gen_cond_dep 'dev-python/pycodestyle[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+ $(python_gen_cond_dep 'dev-python/pyflakes[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+ $(python_gen_cond_dep 'dev-python/pytest-cov[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+ )
+"
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ app-text/tidy-html5
+"
+
+RESTRICT="test" # 1/11 tests fail
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}