summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vine/vine-5.0.0.ebuild')
-rw-r--r--dev-python/vine/vine-5.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/vine/vine-5.0.0.ebuild b/dev-python/vine/vine-5.0.0.ebuild
new file mode 100644
index 000000000000..515868bc33a1
--- /dev/null
+++ b/dev-python/vine/vine-5.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python Promises"
+HOMEPAGE="https://pypi.org/project/vine/ https://github.com/celery/vine"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest