summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/warlock/warlock-1.3.3.ebuild')
-rw-r--r--dev-python/warlock/warlock-1.3.3.ebuild25
1 files changed, 8 insertions, 17 deletions
diff --git a/dev-python/warlock/warlock-1.3.3.ebuild b/dev-python/warlock/warlock-1.3.3.ebuild
index c016724851b8..9aeb1ca4cddd 100644
--- a/dev-python/warlock/warlock-1.3.3.ebuild
+++ b/dev-python/warlock/warlock-1.3.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -13,21 +13,12 @@ SRC_URI="https://github.com/bcwaldon/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.g
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
- <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
- <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
+ <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
-python_test() {
- "${PYTHON}" tests/test_core.py || die
-}
+distutils_enable_tests unittest