summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/watchdog/watchdog-2.1.6.ebuild')
-rw-r--r--dev-python/watchdog/watchdog-2.1.6.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/watchdog/watchdog-2.1.6.ebuild b/dev-python/watchdog/watchdog-2.1.6.ebuild
deleted file mode 100644
index bdf60d233757..000000000000
--- a/dev-python/watchdog/watchdog-2.1.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="https://github.com/gorakhargosh/watchdog"
-SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- default
-}
-
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_inotify_buffer.py::test_move_internal_batch
- )
-
- epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}