summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wcwidth/wcwidth-0.1.5.ebuild')
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.1.5.ebuild b/dev-python/wcwidth/wcwidth-0.1.5.ebuild
new file mode 100644
index 000000000000..c0c6c3f13316
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.python.org/pypi/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -rs --strict wcwidth/tests || die
+}