summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websockets/websockets-10.3.ebuild')
-rw-r--r--dev-python/websockets/websockets-10.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/websockets/websockets-10.3.ebuild b/dev-python/websockets/websockets-10.3.ebuild
new file mode 100644
index 000000000000..1723d0a7cdd0
--- /dev/null
+++ b/dev-python/websockets/websockets-10.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="
+ https://websockets.readthedocs.io/
+ https://github.com/aaugustin/websockets/
+ https://pypi.org/project/websockets/
+"
+SRC_URI="
+ https://github.com/aaugustin/websockets/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very fragile to speed
+ tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
+ )
+
+ epytest tests
+}