summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webtest/webtest-2.0.35.ebuild')
-rw-r--r--dev-python/webtest/webtest-2.0.35.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/webtest/webtest-2.0.35.ebuild b/dev-python/webtest/webtest-2.0.35.ebuild
deleted file mode 100644
index 6b1ffd9087b4..000000000000
--- a/dev-python/webtest/webtest-2.0.35.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="https://pypi.org/project/WebTest/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/paste[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]"
-BDEPEND="
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest