summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.16.0.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.16.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.16.0.ebuild b/dev-python/werkzeug/werkzeug-0.16.0.ebuild
deleted file mode 100644
index 4a26883cb765..000000000000
--- a/dev-python/werkzeug/werkzeug-0.16.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Werkzeug"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
-#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-SRC_URI="https://github.com/pallets/werkzeug/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- # dev_server seems to be broken with PyPy
- # https://github.com/pallets/werkzeug/issues/1668
- # TODO: exclude only failing tests
- [[ ${EPYTHON} == pypy ]] && continue
-
- pytest -vv -p no:httpbin || die "Tests fail with ${EPYTHON}"
-}