summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wstools/wstools-0.4.8.ebuild')
-rw-r--r--dev-python/wstools/wstools-0.4.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/wstools/wstools-0.4.8.ebuild b/dev-python/wstools/wstools-0.4.8.ebuild
new file mode 100644
index 000000000000..857203dfd07d
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/pycontribs/wstools https://pypi.org/project/wstools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.8-setup.patch )
+
+distutils_enable_tests pytest