summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wurlitzer')
-rw-r--r--dev-python/wurlitzer/Manifest1
-rw-r--r--dev-python/wurlitzer/wurlitzer-3.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/Manifest b/dev-python/wurlitzer/Manifest
index 6a2f5f7a9cb4..e269ed961b9a 100644
--- a/dev-python/wurlitzer/Manifest
+++ b/dev-python/wurlitzer/Manifest
@@ -1 +1,2 @@
DIST wurlitzer-3.0.3.tar.gz 10171 BLAKE2B bf0ab15aaf0b693df64e0e9db38309ad1dad117aa97c1f380021ca81153eaf08ef742a97cf7451e72cc3473a2824fe142d8d8cd7ea1b28a367ed5761527c8d6a SHA512 6914ca77af8540bd949b74dfffe58b6ff9de603474e42e973b712f91a11dc906d7753f769932d26106c0543e98f42929741ed4de9ae14601eeadbd0dc5bfca35
+DIST wurlitzer-3.1.0.tar.gz 11571 BLAKE2B 2b7be0f34d1f7b5e15cce51ad749d31e3cd28b9693812aba2c9bcd2b38efc4cf2302abfabf74d11c9929a4951194fc284d05de8c068414626604497e98eb859f SHA512 c285f4169191bca9fb3e4fca884c35d630bbe0b9b9db0952a96888e97f2d27cd82d9defba7fbd2efba14ee2214235743eca1d9e8e79074b8bed2f1af066c0412
diff --git a/dev-python/wurlitzer/wurlitzer-3.1.0.ebuild b/dev-python/wurlitzer/wurlitzer-3.1.0.ebuild
new file mode 100644
index 000000000000..a38e180e1ee4
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-3.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="
+ https://github.com/minrk/wurlitzer/
+ https://pypi.org/project/wurlitzer/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}