summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild')
-rw-r--r--dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild b/dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild
new file mode 100644
index 000000000000..21e90d2bdc5f
--- /dev/null
+++ b/dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
+HOMEPAGE="
+ https://github.com/niccokunzmann/x-wr-timezone/
+ https://pypi.org/project/x-wr-timezone/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/icalendar-5.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)