summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xapp/xapp-2.0.1.ebuild')
-rw-r--r--dev-python/xapp/xapp-2.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/xapp/xapp-2.0.1.ebuild b/dev-python/xapp/xapp-2.0.1.ebuild
new file mode 100644
index 000000000000..8ab0a07bede6
--- /dev/null
+++ b/dev-python/xapp/xapp-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapps"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/xapps[introspection]"
+RDEPEND="${DEPEND}
+ dev-python/psutil[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/python3-xapp-${PV}"