summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xcffib/xcffib-0.6.0.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.6.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/xcffib/xcffib-0.6.0.ebuild b/dev-python/xcffib/xcffib-0.6.0.ebuild
deleted file mode 100644
index 13c878d5dd0c..000000000000
--- a/dev-python/xcffib/xcffib-0.6.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
-HOMEPAGE="https://github.com/tych0/xcffib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="x11-libs/libxcb"
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
- dev-python/six[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- x11-apps/xeyes
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
-
-python_test() {
- nosetests -d -v || die
-}