summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest1
-rw-r--r--dev-python/xkbcommon/xkbcommon-0.8.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index 91101265c16c..f15b86461fb5 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,2 +1 @@
-DIST python-xkbcommon-0.8.gh.tar.gz 26951 BLAKE2B 0d2a649e3fee8baa9345ddca97dc7c77b5d9e10d7ca90cbb29bcc3531f4bba3deee39e610e147054e956310506fb79ebb43c85955b787e55046d67c12b851026 SHA512 ae2640ef89e7ace0468e970762c7be4d3f608701f1abea10174f274c622db28a6e6323cdc5bbbbaaa1065d4c4ddf9f67b75d4c34bb2e9a0bb6260778b15a330a
DIST python-xkbcommon-1.0.gh.tar.gz 27258 BLAKE2B 3106877f8e87f50453a358eec4e6431642b00a6a2bc23d3088ef22379984869ec84cd042a1ac53dd72783f3005dad1efddf3f87410204b88bfde4f9da0044c97 SHA512 c7793d6f5517771006ff5a9c01deb9a37717157d7171af49ff459dc96b3b16a1d2d4c0f1272b5a8f683390de1e8e6a6ff92472f18828c7e38e0f2a1ee6f34f07
diff --git a/dev-python/xkbcommon/xkbcommon-0.8.ebuild b/dev-python/xkbcommon/xkbcommon-0.8.ebuild
deleted file mode 100644
index 1ca6444edeeb..000000000000
--- a/dev-python/xkbcommon/xkbcommon-0.8.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=python-xkbcommon-${PV}
-DESCRIPTION="Python bindings for libxkbcommon using cffi"
-HOMEPAGE="
- https://github.com/sde1000/python-xkbcommon/
- https://pypi.org/project/xkbcommon/
-"
-SRC_URI="
- https://github.com/sde1000/python-xkbcommon/archive/refs/tags/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-# x11-libs/libxkbcommon dep per README
-RDEPEND="
- >=x11-libs/libxkbcommon-${PV}
- $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- ' 'python*')
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf xkbcommon || die
-
- epytest
-}