summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlrd/xlrd-0.9.4.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-0.9.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-0.9.4.ebuild b/dev-python/xlrd/xlrd-0.9.4.ebuild
new file mode 100644
index 000000000000..f187923abde9
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.9.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="
+ http://www.python-excel.org/
+ https://github.com/python-excel/xlrd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.3-column.patch )
+
+python_prepare_all() {
+ # Remove this if examples get reintroduced
+ sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
+}