summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild')
-rw-r--r--dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild b/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild
new file mode 100644
index 000000000000..52f725edf4e2
--- /dev/null
+++ b/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="XStatic-Patternfly"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XStatic Patternfly package"
+HOMEPAGE="https://pypi.org/project/XStatic-Patternfly"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/xstatic[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}