summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yamlpath/yamlpath-3.6.9.ebuild')
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.9.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/yamlpath/yamlpath-3.6.9.ebuild b/dev-python/yamlpath/yamlpath-3.6.9.ebuild
deleted file mode 100644
index 57cf84eea746..000000000000
--- a/dev-python/yamlpath/yamlpath-3.6.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-ruby/hiera-eyaml
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- sed -e '/ruamel\.yaml/d' \
- -e '/pytest-cov/d' \
- -e "/find_packages/s/()/(exclude=\['tests'\])/" \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}