summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zeep')
-rw-r--r--dev-python/zeep/Manifest1
-rw-r--r--dev-python/zeep/zeep-4.2.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zeep/Manifest b/dev-python/zeep/Manifest
index 9077172fa6e2..eb8227a4e8fa 100644
--- a/dev-python/zeep/Manifest
+++ b/dev-python/zeep/Manifest
@@ -1 +1,2 @@
DIST zeep-4.1.0.tar.gz 160333 BLAKE2B d29db92efe048ba854ff14cde062993c3f334cab6cfc122f6db9aa7a1a490c82f93a50ca5028a5f86e316d9ecf567ac40aef10f3e7d8db89376c7d8dea2a2e23 SHA512 acc54f99d21fe401e06418223591bcf8e7f8819e225f892beb0f6e2a1ee359a0da6f9d0aa4212899197c084af37cc56126879b93a22cdad2458e57674bf66ed5
+DIST zeep-4.2.0.tar.gz 161102 BLAKE2B e6d25ec10c1e50d6d3e029d65e0ec28ca70524b82ba67c261099fa970cbb0af320e9085539316ae64736600acce0e69793c081314c01e2de34a026208d8a5bef SHA512 dd7ea6fb80e41ae0ed81ebc26b9d0498685c9801baf0c46c124b0341e78127f521e429c7b55a2056018f3229128294f2715f8794ae8c00f313435cd8663c63f6
diff --git a/dev-python/zeep/zeep-4.2.0.ebuild b/dev-python/zeep/zeep-4.2.0.ebuild
new file mode 100644
index 000000000000..adcaf749a07b
--- /dev/null
+++ b/dev-python/zeep/zeep-4.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
+HOMEPAGE="https://docs.python-zeep.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="async"
+
+RDEPEND="
+ >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aioresponses[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/python-xmlsec[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # broken by new pytest-httpx?
+ tests/test_async_transport.py::test_load
+ tests/test_async_transport.py::test_load_cache
+ tests/test_async_transport.py::test_post
+ tests/test_async_transport.py::test_http_error
+)