summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.63.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 3d430384de95..db966c055f70 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST zeroconf-0.62.0.tar.gz 141269 BLAKE2B 17efd98394155e415cc9b9b6ff7b2ec6d702613a38e4af8d8e168155a2ecef20f16d4864dc2c62833c9d186d937eca9a5b25846efdc0c21d7bf29f1d911228ca SHA512 d923f23af59dfa09977ec45507c8a02d68a49077652a3fe7d8f23a62e45c525bb431ee5a82c51012d8ba77a7285eaae963a84f0727110780392b0fb7c9966038
+DIST zeroconf-0.63.0.tar.gz 141580 BLAKE2B 22267e2be9118c91b5d7638843e89de0a2838eb1ebca2c233038fc202b8648256193fd8d61523960e1fce110ef7e3c3c06190f5369f700c02cbd047a036a362e SHA512 b899838ddae288b0f0483ca6950871d88ee387769507fe803a68df1cd5657bf9eee2aeecfc2e7685ded5327e70e04cfe445b564f16e3e9191112ddaae7deda18
diff --git a/dev-python/zeroconf/zeroconf-0.63.0.ebuild b/dev-python/zeroconf/zeroconf-0.63.0.ebuild
new file mode 100644
index 000000000000..29801ba74dbb
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.63.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}