summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.6.0.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 1f3863b5bce0..da4ee7e9e7c0 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1 @@
-DIST zipp-3.6.0.tar.gz 13047 BLAKE2B 2e3f5fd0acf9f931f5a74957e9ae29f12a42bc824eb36d769720282ec0413d90b0b45f0524f3b319ce614f43c061ae324fb29f7f2a83e7aeb393283827bca5d1 SHA512 8e21b0a757ed9ebddeca43d3e4b64549dc4e59f781704626b0b2b0a117752b84798a0484cceedd4684ee0459643df4d0f479e64a143c8d9337d2b66951a7b227
DIST zipp-3.7.0.tar.gz 12989 BLAKE2B 8a315dfd28c8aa1d5a568699886ea47b34000381981d1f4e578bcc10d7c9dc772bfd99ae9d720836e300dd1aaa5e12f0667bbe40d69668306f90aed23ec0cc8f SHA512 bf0c00382273453286ce597fb5a0059b8b279edd01dc4f2d5accef41cc53d69ddda1a2b00f4c38ed4057eeac69ef225ba4bd3a70a16da025b33947cdd6a69ed8
diff --git a/dev-python/zipp/zipp-3.6.0.ebuild b/dev-python/zipp/zipp-3.6.0.ebuild
deleted file mode 100644
index aa0bec0ed728..000000000000
--- a/dev-python/zipp/zipp-3.6.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="https://github.com/jaraco/zipp"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
- test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # speed tests are flaky by design
- test_zipp.py::TestPath::test_implied_dirs_performance
-)
-
-EPYTEST_IGNORE=(
- # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
- # by ensuring only zipp from ${BUILD_DIR} is loaded
- zipp.py
-)
-
-python_prepare_all() {
- # dep of disabled test
- sed -i -e '/func_timeout/d' test_zipp.py || die
- distutils-r1_python_prepare_all
-}