summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-exceptions/zope-exceptions-4.4.ebuild')
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.4.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
index 61b483dc978a..e3e9b985874f 100644
--- a/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
+++ b/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -14,6 +14,7 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="General purpose exceptions for Zope packages"
HOMEPAGE="https://pypi.org/project/zope.exceptions/ https://github.com/zopefoundation/zope.exceptions"
SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="ZPL"
SLOT="0"
@@ -23,7 +24,9 @@ RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
BDEPEND="test? ( dev-python/zope-testrunner[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-test-py3.10.patch"
+)
distutils_enable_tests setup.py