summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-schema/zope-schema-6.1.0.ebuild')
-rw-r--r--dev-python/zope-schema/zope-schema-6.1.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/zope-schema/zope-schema-6.1.0.ebuild b/dev-python/zope-schema/zope-schema-6.1.0.ebuild
deleted file mode 100644
index 26909a7d20b4..000000000000
--- a/dev-python/zope-schema/zope-schema-6.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope schema Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.schema http://docs.zope.org/zope.schema/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-RDEPEND="
- dev-python/zope-event[${PYTHON_USEDEP}]
- >=dev-python/zope-interface-5.0.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-python_test() {
- eunittest src
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}